I ran into a problem while installing neutron. This error is rather common (as seen through googling) but the solution was hard to find. This is what I found that worked for me. YMMV.

The full error is as follows:

Running setup.py (path:/tmp/pip_build_root/ryu/setup.py) egg_info for
package ryu
error in ryu setup command: Invalid environment marker: (python_version
>= '2.7')
Complete output from command python setup.py egg_info:
error in ryu setup command: Invalid environment marker: (python_version
>= '2.7')

----------------------------------------
Cleaning up...
Removing temporary dir /tmp/pip_build_root...
Command python setup.py egg_info failed with error code 1 in
/tmp/pip_build_root/ryu
Exception information:
Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 122, in
main
status = self.run(options, args)
File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line
278, in run
requirement_set.prepare_files(finder, force_root_egg_info=self.bundle,
bundle=self.bundle)
File "/usr/lib/python2.7/dist-packages/pip/req.py", line 1230, in
prepare_files
req_to_install.run_egg_info()
File "/usr/lib/python2.7/dist-packages/pip/req.py", line 326, in
run_egg_info
command_desc='python setup.py egg_info')
File "/usr/lib/python2.7/dist-packages/pip/util.py", line 715, in
call_subprocess
% (command_desc, proc.returncode, cwd))
InstallationError: Command python

This was fixed by ensuring that my version of setuptools (not the system package of the same name) was version 18.0.1 or newer.

I got this information from the ryu mailing list.